Eclipseにe(fx)clipseをインストールできない場合の対処方法を備忘記録として残しておく。e(fx)clipseのインストール手順はこちらのサイトで確認できる。

Eclipse Kepler (4.3.x)で、以下のエラーが出てインストールできない場合は、

1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software being installed: e(fx)clipse – IDE – Kepler 0.9.0.201401250805(org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201401250805)
Missing requirement: e(fx)clipse – IDE – FXGraph 0.9.0.201401250805(org.eclipse.fx.ide.fxgraph.feature.feature.group 0.9.0.201401250805) requires’org.eclipse.xtext.sdk.feature.group 2.5.0′ but it could not be found

作業対象に「Kepler – http://download.eclipse.org/releases/kepler」を選択して、「プログラミング言語->Xtend SDK」をインストールする。この後e(fx)clipseをインストールするが、Xtend SDKのバージョンがあっていなければ、以下のような画面が出るが、そのまま次へと押していけばよい。

programming-eclipse-efxclipse-install

関連する記事

  • Python KNPを用いて係り受け構造を抽出する方法Python KNPを用いて係り受け構造を抽出する方法 Ubuntu14.04環境で、Python3と日本語構文・格・照応解析システムKNPを用いて係る語と受ける語のペアを抽出する方法をご紹介する。 係り受け構造を抽出するPython3のソースコードは次である。 from pyknp import KNP def […]
  • Ubuntu14.04とPython3でMeCabを使う方法Ubuntu14.04とPython3でMeCabを使う方法 MeCabは各種スクリプト言語(perl、ruby、python、Java)から、各言語バイディングで利用できるようになっている。 しかし、Pythonで用意されているのはPython2系のもので、残念ながらPython3系では使えない。 そこで、ここでは用意されているPython2系バイディングをPython3系に変換して使用する方法をお伝えする。 MeCab […]
  • Ubuntu14.04でPython3に対応したmatplotlibを使用するための手順Ubuntu14.04でPython3に対応したmatplotlibを使用するための手順 Ubuntu14.04でPython3に対応したmatplotlibを使用するための手順をご紹介する。 1. […]
  • Python pyqueryを用いて簡単にウェブスクレイピングPython pyqueryを用いて簡単にウェブスクレイピング Pythonでpyqueryパッケージを用いて、ウェブスクレイピングを行う方法をご紹介する。ウェブ上には様々なデータがあるが、必要なデータがいつもファイルとしてダウンロードできるとは限らない。ここでご紹介する方法は、htmlファイルを直接解析して、必要な情報を取得するという方法である。 それでは、さっそく見ていこう。 Ubuntu […]
  • matplotlibで箱ひげ図を表示する方法matplotlibで箱ひげ図を表示する方法 Python3でmatplotlibを用いて、箱ひげ図を表示する方法をお伝えする。 Ubuntu14.04環境で動作することを確認している。 一つ注意点として、日本語に対応させるために、ここでは「IPAexGothic」を用いている。 import matplotlib as mpl import matplotlib.pyplot as […]
Eclipseにe(fx)clipseをインストールできない場合の対処方法